QAWeb Relay installation fails with error message: program had an internal error

Article number: [5214] - Legacy code: [7526]

Problem

While installing QAWeb Relay, you receive an error message similar to this one:

After clicking the OK button, the installation rolls back and closes. QAWeb Relay is not installed.

Root cause

In most cases, SSL certificate issues are causing this issue. To be sure it is related to SSL certificates, verify the following:

  1. Open Windows Explorer
  2. On your Pc or server, locate and open the following file: c:\relayinstaller.txt
  3. Scroll down to the bottom of the log file and then slowly scroll back up while looking for an error message that looks like the following:
    Caused by: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

If this information is present, then the issue is most likely to be related to an SSL certificate issue. In case you cannot find this information in the installation log files, then you may be encountering a different issue. Contact Barco customer service in this case.

Two main root causes have been identified:

  1. Proxy changing SSL certificates: The messages from QAWeb Relay to QAWeb Server are passing through a proxy which is changing the SSL certificates. Please check with the IT department or network administrators if this is the case.
  2. Corrupt keystore: In case of a reinstallation or upgrade of QAWeb Relay (for instance to solve connectivity issues), it could be that a corrupt keystore is still in your system. This keystore keeps the digital keys which are required for secure SSL communication.

Solution

Both root causes are unrelated to each other so in both situations, you need a different solution:

  1. In case of the proxy changing the certificates, you will have to align with IT or network administrators to see what can be done about this. One potential solution is to configure the proxy so it can be bypassed by the QAWeb Relay application (to the 2 QAWeb Server IP addresses). Another potential solution is to configure the proxy to not change the SSL certificates when messages between QAWeb Relay and QAWeb Server pass through it.
  2. In the case of a corrupt keystore, verify if files are left on the file system after the uninstallation of QAWeb Relay and remove them if so. The following folder needs to be either empty or completely removed before restarting the installation: C:\Program Files\Barco\QAWebRelay\

Properties

Last updated Aug 2, 2023